Si vous utilisez WAMP pour développer et bidouiller en local sur votre machine, vous pourriez avoir envie d'utiliser le système de paquet composer.

composer-error

De mon côté je me suis heurté à une erreur lors de l'installation :

The openssl extension is missing, which means that secure HTTPS transfers are impossible.

Rien de méchant. Il vous suffit d'activer l'extension openssl en éditant le fichier :

Dans mon cas il s'agit de ce répertoire :

Recherche cette ligne :

Et supprimer le point virgule ";" pour dé-commenter la ligne et activer le module. Si WAMP était en fonctionnement au moment ou vous avez édité le fichier, redémarrez les services. Notez que l'activation du module openssl via le menu WAMP était foireuse chez moi, d'où ce guide.

De retour dans l'installation de composer, faites "back" puis "next" et cela devrait fonctionner.

Auteur : Mr Xhark

Fondateur du blog et passionné par les nouvelles techno, suivez-moi sur twitter